<!DOCTYPE html>
<html lang="en-gb" dir="ltr">
<head>
    <base href="https://www.graphic.com.gh/news/politics/amidu-s-appointment-should-end-witch-hunting-cries-akufo-addo.html" />    <link href="https://www.graphic.com.gh/templates/ghananews/images/designer/ecfc2c86b1509084809896ecd84af0f4_graphic1_favLogoextra.png" rel="icon" type="image/x-icon" />
    <script>
    var themeHasJQuery = !!window.jQuery;
</script>
<script src="/templates/ghananews/jquery.js?version=1.0.2642"></script>
<script>
    window._$ = jQuery.noConflict(themeHasJQuery);
</script>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
<script src="/templates/ghananews/bootstrap.min.js?version=1.0.2642"></script>
<!--[if lte IE 9]>
<script src="/templates/ghananews/layout.ie.js?version=1.0.2642"></script>
<link rel="stylesheet" href="/templates/ghananews/layout.ie.css?version=1.0.2642" media="screen"/>
<![endif]-->
<link class="" href='//fonts.googleapis.com/css?family=Open+Sans:300,300italic,regular,italic,600,600italic,700,700italic,800,800italic|Francois+One:regular|Amaranth:regular,italic,700,700italic|Ubuntu:300,300italic,regular,italic,500,500italic,700,700italic|Roboto+Condensed:300,300italic,regular,italic,700,700italic|Actor:regular|Roboto:100,100italic,300,300italic,regular,italic,500,500italic,700,700italic,900,900italic&subset=latin' rel='stylesheet' type='text/css'>
<script src="/templates/ghananews/layout.core.js?version=1.0.2642"></script>
    
    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
	<meta name="keywords" content="President, NPP. NDC, Ghana politics, Ghana Parliament, Ghana news" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:site" content="@GraphicOnline" />
	<meta name="twitter:creator" content="@graphicgh" />
	<meta name="twitter:title" content="Amidu’s appointment should end witch-hunting cries – Akufo-Addo" />
	<meta name="twitter:image" content="https://www.graphic.com.gh/images/2018/july/03/nana_mauritius.jpg" />
	<meta name="twitter:description" content="President Nana Addo Dankwa Akufo-Addo says the appointment of Mr. Martin Amidu as Ghana’s first Special Prosecutor will deny persons who will be investigated and prosecuted for engaging in acts of corruption, the often-cited refrain of witch-hunting." />
	<meta name="robots" content="index, follow" />
	<meta name="author" content="Graphic.com.gh" />
	<meta name="canonical" content="https://www.graphic.com.gh/news/politics/amidu-s-appointment-should-end-witch-hunting-cries-akufo-addo.html" />
	<meta name="description" content="President Nana Addo Dankwa Akufo-Addo says the appointment of Mr. Martin Amidu as Ghana’s first Special Prosecutor will deny persons who will be investigated and prosecuted for engaging in acts of corruption, the often-cited refrain of witch-hunting." />
	<meta name="generator" content="Joomla! - Open Source Content Management" />
	<title>Amidu’s appointment should end witch-hunting cries – Akufo-Addo - Graphic Online</title>
	<link href="https://cdn.ampproject.org/c/s/www.graphic.com.gh/news/politics/amidu-s-appointment-should-end-witch-hunting-cries-akufo-addo.amp.html" rel="amphtml" />
	<link href="https://www.graphic.com.gh/news/politics/amidu-s-appointment-should-end-witch-hunting-cries-akufo-addo.html" rel="canonical" />
	<link href="/modules/mod_raxo_allmode/tmpl/allmode-list/allmode-list.v2.css" rel="stylesheet" type="text/css" />
	<meta property="og:title" content="Amidu’s appointment should end witch-hunting cries – Akufo-Addo" />
	<meta property="og:type" content="article" />
	<meta property="og:image" content="https://www.graphic.com.gh/images/2018/july/03/nana_mauritius.jpg" />
	<meta property="og:url" content="https://www.graphic.com.gh/news/politics/amidu-s-appointment-should-end-witch-hunting-cries-akufo-addo.html" />
	<meta property="og:site_name" content="Graphic Online" />
	<meta property="og:description" content="President Nana Addo Dankwa Akufo-Addo says the appointment of Mr. Martin Amidu as Ghana’s first Special Prosecutor will deny persons who will be investigated and prosecuted for engaging in acts of corruption, the often-cited refrain of witch-hunting." />
	<meta property="fb:app_id" content="342494502508165" />
	<meta property="og:site_name" content="Graphic Online - Ghana News
og:image:width" />
	<!-- Start: Google Structured Data -->
             <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "WebSite", "url": "https://www.graphic.com.gh", "potentialAction": { "@type": "SearchAction", "target": "https://www.graphic.com.gh/index.php?option=com_search&searchphrase=all&searchword={search_term}", "query-input": "required name=search_term" } } </script> <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "Organization", "url": "https://www.graphic.com.gh", "logo": "https://www.graphic.com.gh/images/2018/feb/onlinelogo.png" } </script> <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "Organization", "name": "Graphic Online", "url": "https://www.graphic.com.gh", "sameAs": [ "https://www.facebook.com/dailygraphicghana", "https://twitter.com/graphicgh", "https://plus.google.com/+dailygraphic", "https://www.instagram.com/graphic.com.gh", "https://www.youtube.com/user/GraphicGh/" ] } </script> <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "BreadcrumbList", "itemListElement": [{ "@type": "ListItem", "position": 1, "item": { "@id": "https://www.graphic.com.gh/", "name": "Ghana News Homepage" } },{ "@type": "ListItem", "position": 2, "item": { "@id": "https://www.graphic.com.gh/news.html", "name": "Headlines" } },{ "@type": "ListItem", "position": 3, "item": { "@id": "https://www.graphic.com.gh/news/politics.html", "name": "Politics" } },{ "@type": "ListItem", "position": 4, "item": { "@id": "https://www.graphic.com.gh/news/politics/amidu-s-appointment-should-end-witch-hunting-cries-akufo-addo.html", "name": "Amidu’s appointment should end witch-hunting cries – Akufo-Addo" } }] } </script>
            <!-- End: Google Structured Data -->
	<meta property="fb:pages" content="122108447901948" />
<meta property="fb:admins" content="10157057759915251">
<meta property="article:publisher" content="https://www.facebook.com/dailygraphicghana" />
<meta property="og:site_name" content="Graphic Online - Ghana News" />
<meta property="og:image:width" content="600"/>
<meta property="og:image:height" content="400"/>
<script async src="//www.graphic.com.gh/adsonline/www/delivery/asyncjs.php"></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" defer></script>
<script type="text/javascript" src="//platform-api.sharethis.com/js/sharethis.js#property=58b94fe43f23ef0012b98ccb&product=sticky-share-buttons" defer></script>
<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"DCywq1Fx9f207i", domain:"graphic.com.gh",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=DCywq1Fx9f207i" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript --> 
<meta http-equiv="refresh" content="1000"/>
<!-- Start Geo Meta Tags-->
<meta name="geo.placename" content="Greater Accra, Accra, Ghana">
<meta name="geo.position" content="5.5500;-0.2500">
<meta name="geo.region" content="GH-AA">
<meta name="geo.country" content="GH">
<meta name="ICBM" content="5.5500, -0.2500">
<!-- End Geo Meta Tags-->
<!-- begin auto ads-->
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1220784161199635",
          enable_page_level_ads: true
     });
</script>
<!-- end auto ads-->
<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '189845911834349');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=189845911834349&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/graphiconline1/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
<meta name="copyright" content="&copy;  Graphic.com.gh. All rights reserved. Graphic Online is a subsidiary of The Graphic Communications Group Limited. (https://corporate.graphic.com.gh">
        <link rel="stylesheet" href="/templates/ghananews/css/bootstrap.min.css?version=1.0.2642" media="screen" />
            <link rel="stylesheet" href="/templates/ghananews/css/template.min.css?version=1.0.2642" media="screen" />
            <script src="/templates/ghananews/script.js?version=1.0.2642"></script>
    <script async src="/./paceprogressbar/pace.min.js"></script>
<link href="/./paceprogressbar/pace-theme-flash.css" rel="stylesheet" />
<link href="/./cssedits/custom.css" rel="stylesheet" />
<link rel="apple-touch-icon" sizes="72x72" href="/./favicons/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="114x114" href="/./favicons/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="/./favicons/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="/./favicons/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="/./favicons/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="/./favicons/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192"  href="/./favicons/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="96x96" href="/./favicons/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="/./favicons/favicon-16x16.png">
<link rel="manifest" href="/manifest.json">
<meta name="theme-color" content="#bb1919">
<meta name="msapplication-TileColor" content="#bb1919">
<meta name="msapplication-TileImage" content="./favicons/ms-icon-144x144.png">


<meta name="google-site-verification" content="ePVTo-YiX6b27Yk4zujBVQCS1_XEOF6vSk6yQqQTRfc" />




<!-- Start PushCrew Asynchronous Code -->
<script type='text/javascript'>
(function(p,u,s,h) {
    p._pcq = p._pcq || [];
    p._pcq.push(['_currentTime', Date.now()]);
    s = u.createElement('script'); s.type = 'text/javascript'; s.async = true;
    s.src = 'https://cdn.pushcrew.com/js/5ef8f5eec1ec815a6a401eda9b8503cd.js';
    h = u.getElementsByTagName('script')[0]; h.parentNode.insertBefore(s, h);
})(window,document);
</script>
<!-- End PushCrew Asynchronous Code -->


</head>
<body class=" bootstrap bd-body-13  bd-pagebackground-326 bd-margins">
    <header class=" bd-headerarea-1 bd-margins">
        <div class=" bd-customhtml-2 bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
    <div class="bd-container-inner bd-content-element">
        <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = 'https://connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.12&appId=342494502508165&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>    </div>
</div>
	
		<div class=" bd-layoutbox-1 hidden-xs bd-no-margins clearfix">
    <div class="bd-container-inner">
        <form id="search-8" role="form" class=" bd-search-8 hidden-sm hidden-xs bd-no-margins form-inline" name="search" action="/index.php" method="post">
    <div class="bd-container-inner">
        <input type="hidden" name="task" value="search">
        <input type="hidden" name="option" value="com_search">
        <div class="bd-search-wrapper">
            
                
                <div class="bd-input-wrapper">
                    <input type="text" name="searchword" class=" bd-bootstrapinput-11 form-control input-sm" placeholder="Search Graphic Online">
                </div>
                
                <div class="bd-button-wrapper">
                    <input type="submit" class=" bd-button-18 bd-no-margins" value="Search" link-disable="true">
                </div>
        </div>
        <script>
            (function (jQuery, $) {
                jQuery('.bd-search-8 .bd-icon-58').on('click', function (e) {
                    e.preventDefault();
                    jQuery('#search-8').submit();
                });
            })(window._$, window._$);
        </script>
    </div>
</form>
	
		            
        <div class=" bd-topmenu-1 hidden-xs" data-responsive-menu="true">
                        
                <div class=" bd-responsivemenu-1 collapse-button">
    <div class="bd-container-inner">
        <div class="bd-menuitem-3 ">
            <a  data-toggle="collapse"
                data-target=".bd-topmenu-1 .collapse-button + .navbar-collapse"
                href="#" onclick="return false;">
                    <span></span>
            </a>
        </div>
    </div>
</div>
                <div class="navbar-collapse collapse">
                <div class=" bd-horizontalmenu-2 clearfix">
                    <div class="bd-container-inner">
                        <ul class=" bd-menu-3 nav nav-pills navbar-left" >
<li class=" bd-menuitem-4 item-115">
<a title="For Latest and Trending Ghana business news" href="https://graphicbusinessonline.com" rel="prefetch"><span>Graphic Business</span></a></li><li class=" bd-menuitem-4 item-116">
<a title="Graphic Communications Group Ltd Corporate Page" href="https://corporate.graphic.com.gh" rel="prefetch" target="_blank"><span>GCGL</span></a></li><li class=" bd-menuitem-4 item-118">
<a title="Read the digital Replicas of Graphic Publications online" href="https://epaper.graphic.com.gh" rel="prefetch" target="_blank"><span>E-Paper</span></a></li><li class=" bd-menuitem-4 item-322">
<a title="Graphic SHOWBIZ Online" href="/showbiz/" target="_blank"><span>GRAPHIC SHOWBIZ</span></a></li><li class=" bd-menuitem-4 item-323">
<a title="Graphic SPORTS: Homepage" href="/graphicsports/"><span>GRAPHIC SPORTS</span></a></li></ul>                    </div>
                </div>
            
                </div>
                    </div>
        
    	
		        	
		<a class=" bd-logo-3" href="https://www.graphic.com.gh"
 title="Homepage of Graphic Online">
<img class=" bd-imagestyles-11" src="https://www.graphic.com.gh//favicons/apple-icon-180x180.png" alt="Graphic Online">
</a>
    </div>
</div>
	
		<div class=" bd-layoutbox-4 bd-no-margins clearfix">
    <div class="bd-container-inner">
        <form id="search-3" role="form" class=" bd-search-3 hidden-md hidden-sm hidden-xs hidden-lg bd-no-margins form-inline" name="search" action="/index.php" method="post">
    <div class="bd-container-inner">
        <input type="hidden" name="task" value="search">
        <input type="hidden" name="option" value="com_search">
        <div class="bd-search-wrapper">
            
                
                <div class="bd-input-wrapper">
                    <input type="text" name="searchword" class=" bd-bootstrapinput-9 form-control" placeholder="Search Here">
                </div>
                
                <div class="bd-button-wrapper">
                    <input type="submit" class=" bd-button-12 bd-no-margins" value="Search" link-disable="true">
                </div>
        </div>
        <script>
            (function (jQuery, $) {
                jQuery('.bd-search-3 .bd-icon-4').on('click', function (e) {
                    e.preventDefault();
                    jQuery('#search-3').submit();
                });
            })(window._$, window._$);
        </script>
    </div>
</form>
	
		<form id="search-10" role="form" class=" bd-search-10 hidden-md hidden-lg form-inline" name="search" action="/index.php" method="post">
    <div class="bd-container-inner">
        <input type="hidden" name="task" value="search">
        <input type="hidden" name="option" value="com_search">
        <div class="bd-search-wrapper">
            
                <input type="text" name="searchword" class=" bd-bootstrapinput-6 form-control input-sm" placeholder="Search">
                <a href="#" class="bd-icon-13 bd-icon " link-disable="true"></a>
        </div>
        <script>
            (function (jQuery, $) {
                jQuery('.bd-search-10 .bd-icon-13').on('click', function (e) {
                    e.preventDefault();
                    jQuery('#search-10').submit();
                });
            })(window._$, window._$);
        </script>
    </div>
</form>
	
		<a class=" bd-logo-2 bd-no-margins" href="https://www.graphic.com.gh">
<img class=" bd-imagestyles" src="https://www.graphic.com.gh//favicons/apple-icon-180x180.png" alt="Graphic Online">
</a>
	
		<h3 class=" bd-textblock-2 bd-content-element">
    Graphic Online&nbsp;</h3>
    </div>
</div>
	
		<div data-affix
     data-offset=""
     data-fix-at-screen="top"
     data-clip-at-control="top"
     
 data-enable-lg
     
 data-enable-md
     
 data-enable-sm
     
 data-enable-xs
     class=" bd-affix-4 bd-no-margins bd-margins "><div class=" bd-layoutbox-5  bd-no-margins bd-no-margins clearfix">
    <div class="bd-container-inner">
                    
        <nav class=" bd-hmenu-1"  data-responsive-menu="true" data-responsive-levels="expand on click" data-responsive-type="offcanvas" data-close-icon="bd-icon-150" data-offcanvas-delay="0ms" data-offcanvas-duration="700ms" data-offcanvas-timing-function="ease">
                        
                <div class=" bd-responsivemenu-11 collapse-button">
    <div class="bd-container-inner">
        <div class="bd-menuitem-13 ">
            <a  data-toggle="collapse"
                data-target=".bd-hmenu-1 .collapse-button + .navbar-collapse"
                href="#" onclick="return false;">
                    <span>Menu</span>
            </a>
        </div>
    </div>
</div>
                <div class="navbar-collapse collapse width">
            <div class=" bd-horizontalmenu-1 clearfix">
    <div class="bd-container-inner">
                
<ul class=" bd-menu-1 nav navbar-left nav-pills" >
                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-101 ">
<a title="Ghana News Homepage: Latest News in Ghana and More" href="/"><span>HOME</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item bd-submenu-icon-only item-215  deeper parent">
<a class="  active" title="Ghana Local News Headlines" href="/news.html"><span>Headlines</span></a>        <div class="bd-menu-2-popup">
                            <ul class=" bd-menu-2 ">
                                            
        <li class=" bd-menuitem-2 bd-sub-item item-111 ">
<a title="General News in Ghana today" href="/news/general-news.html"><span>General News</span></a></li>                        
        <li class=" bd-menuitem-2 bd-sub-item item-110  current">
<a class="  active" title="Ghana Politics and governance news" href="/news/politics.html"><span>Politics</span></a></li>                        
        <li class=" bd-menuitem-2 bd-sub-item item-231 ">
<a title="Ghana Education News" href="/news/education.html"><span>Education</span></a></li>                        
        <li class=" bd-menuitem-2 bd-sub-item item-232 ">
<a href="/news/health.html"><span>Health</span></a></li></ul></div></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-112  parent">
<a title="Graphic Business Ghana Business News and More" href="/business.html"><span>Business</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-113  parent">
<a title="Ghana Entertainment and celebrity News for today" href="/entertainment.html"><span>Showbiz</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-205  parent">
<a title="General Sports News  - Graphic SPORTS" href="/sports.html"><span>GraphicSports</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-133  parent">
<a href="/international.html"><span>World</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-104  parent">
<a href="/features.html"><span>Features</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-103  parent">
<a href="/junior-graphic.html"><span>Juniors</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-105  parent">
<a href="/lifestyle.html"><span>Lifestyle</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-184  parent">
<a href="/ghana-regional-news.html"><span>Regional News</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-277 ">
<a title="Daily Graphic Editorials " href="/daily-graphic-editorials.html"><span>Editorials</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-285 ">
<a title="Graphic Online Photo Gallery Page." href="http://photos.graphic.com.gh"><span>Photo Gallery</span></a></li>                </ul>    </div>
</div>                <div class=" bd-menuoverlay-16 bd-menu-overlay"></div>
            
                </div>
                    </nav>
        
        </div>
</div>
</div>
</header>
	
		    
        <div class=" bd-joomlaposition-8 clearfix" >
            <div class=" bd-block-143 bd-own-margins  visible-xs" >
            
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <!-- GRAPHIC ONLINE ADS Asynchronous JS Tag (click tracking for: Revive Adserver) - -->
<ins data-revive-zoneid="7" data-revive-ct0="{clickurl_enc}" data-revive-id="9498a47af2f5e17dd932fffda2cedac3"></ins>
<script async src="//www.graphic.com.gh/adsonline/www/delivery/asyncjs.php"></script>    </div>
    
</div>
        <div class=" bd-block-143 bd-own-margins  visible-lg" >
            
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <ins data-revive-zoneid="6" data-revive-ct0="{clickurl_enc}" data-revive-id="9498a47af2f5e17dd932fffda2cedac3"></ins>    </div>
    
</div>
        </div>
        	
		<div class=" bd-stretchtobottom-3 bd-stretch-to-bottom" data-control-selector=".bd-contentlayout-15">
<div class="bd-contentlayout-15  bd-sheetstyles-17  bd-no-margins bd-margins" >
    <div class="bd-container-inner">

        <div class="bd-flex-vertical bd-stretch-inner bd-contentlayout-offset">
            
            <div class="bd-flex-horizontal bd-flex-wide bd-no-margins">
                
                     <aside class="bd-sidebararea-3-column hidden-sm hidden-xs bd-no-margins  bd-flex-vertical bd-flex-fixed ">
                <div class="bd-sidebararea-3 hidden-sm hidden-xs bd-no-margins bd-flex-wide  bd-contentlayout-offset">
                    
                    <div class=" bd-joomlaposition-23 hidden-sm hidden-xs clearfix" >
            <div class=" bd-block-43 bd-own-margins  visible-lg" >
            
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <ins data-revive-zoneid="11" data-revive-ct0="{clickurl_enc}" data-revive-id="9498a47af2f5e17dd932fffda2cedac3"></ins>    </div>
    
</div>
    

<div class="data-control-id-2779 bd-vmenu-1 hidden-xs" data-responsive-menu="true" data-responsive-levels="expand on click">
    <div class="data-control-id-2778 bd-block-2 bd-own-margins  vmenu">
                <div class="data-control-id-2745 bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
            <h4>News Categories</h4>
        </div>
                <div class="data-control-id-2777 bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed shape-only">
            <div class="data-control-id-200674 bd-verticalmenu-3">
                <div class="bd-container-inner">
                                        
<ul class="data-control-id-200675 bd-menu-23 nav nav-pills" >
                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-220">
<a title="Ghana News Homepage: Credible News in Ghana and More" href="/?template=ghananews&is_preview=on"><span>Home</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-221">
<a title="General and local News in Ghana today" href="/news/general-news.html?template=ghananews&is_preview=on"><span>General News</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-226">
<a class="  active" title="Ghana Political News | news in Ghana | NPP news | NDC News |" href="/news/politics.html?template=ghananews&is_preview=on"><span>Ghana Politics</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-224">
<a title="Ghana Energy and oil and gas news" href="/business/oil-gas.html?template=ghananews&is_preview=on"><span>Oil &amp; Gas</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-310">
<a title="Ghana's telecoms industry news" href="/business/telecom.html?template=ghananews&is_preview=on"><span>Telecoms</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-311">
<a title="Native Daughter Column by Ajoa Yeboah-Afari" href="/native-daughter-column.html?template=ghananews&is_preview=on"><span>Native Daughter</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-312">
<a title="Kobby Asmah: Civic Realities Column" href="/civic-realities-column.html?template=ghananews&is_preview=on"><span>Civic Realities</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-314">
<a title="KB ASANTE: Voice From Afar Column" href="/features/voice-from-afar.html?template=ghananews&is_preview=on"><span>Voice From Afar</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-228">
<a title="Entertainment News in Ghana and celebrity news" href="/entertainment.html?template=ghananews&is_preview=on"><span>Showbiz</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-313">
<a title="Ghana Education News" href="/news/education.html?template=ghananews&is_preview=on"><span>Education</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-237">
<a title="All Ghana Sports News and Black Stars" href="/sports.html?template=ghananews&is_preview=on"><span>GraphicSports</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-245">
<a title="Opinions and Feature articles" href="/features/opinion.html?template=ghananews&is_preview=on"><span>Opinions</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-260">
<a title="Lifestyle, Relationships Tips, Marriage Advice and More " href="/lifestyle/relationships.html?template=ghananews&is_preview=on"><span>Relationships</span></a></li>                                        </ul>                </div>
            </div>
        </div>
    </div>
</div>



<div class="data-control-id-2779 bd-vmenu-1 hidden-xs" data-responsive-menu="true" data-responsive-levels="expand on click">
    <div class="data-control-id-2778 bd-block-2 bd-own-margins  vmenu">
                <div class="data-control-id-2745 bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
            <h4>Regional News</h4>
        </div>
                <div class="data-control-id-2777 bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed shape-only">
            <div class="data-control-id-200674 bd-verticalmenu-3">
                <div class="bd-container-inner">
                                        
<ul class="data-control-id-200675 bd-menu-23 nav nav-pills" >
                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-281">
<a title="Accra news today: news in Accra Ghana" href="/ghana-regional-news/accra.html?template=ghananews&is_preview=on"><span>Greater Accra</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-282">
<a title="News in Kumasi, Ejisu, Bantama and Ashanti Region of Ghana" href="/ghana-regional-news/ashanti-region-news.html?template=ghananews&is_preview=on"><span>Ashanti Region</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-191">
<a title="News in Central Region of Ghana" href="/ghana-regional-news/central-region-news.html?template=ghananews&is_preview=on"><span>Central Region</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-197">
<a title="Ghana news | Brong Ahafo" href="/ghana-regional-news/brong-ahafo-region-news.html?template=ghananews&is_preview=on"><span>Brong Ahafo Region</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-192">
<a title="Ghana news | Tamale news | northern Ghana news" href="/ghana-regional-news/northern-regional-news.html?template=ghananews&is_preview=on"><span>Northern Region</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-198">
<a title="Bolga news | news in Upper East Ghana" href="/ghana-regional-news/upper-east-regional-news.html?template=ghananews&is_preview=on"><span>Upper East Region</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-199">
<a title="news in Wa | Upper West region | Ghana news" href="/ghana-regional-news/upper-west-region-news.html?template=ghananews&is_preview=on"><span>Upper West Region</span></a></li>                                                                            <li class="data-control-id-200676 bd-menuitem-23 item-201">
<a title="news in Keta | Ho | Aflao and All Volta region of Ghana" href="/ghana-regional-news/volta-region-news.html?template=ghananews&is_preview=on"><span>Volta Region</span></a></li>                                        </ul>                </div>
            </div>
        </div>
    </div>
</div>

    </div>                    
                </div>
            </aside>
                        <div class="bd-flex-vertical bd-flex-wide bd-no-margins">
                    

                    <div class=" bd-layoutitemsbox-7 bd-flex-wide bd-no-margins">
    <div class=" bd-content-16">
    

<div class=" bd-blog-3 bd-no-margins "  >
    <div class="bd-container-inner">
    
        <div class=" bd-grid-6 bd-margins">
          <div class="container-fluid">
            <div class="separated-grid row">
                <div class="separated-item-38 col-md-12 ">
                    
                    <div class="bd-griditem-38">
            
        <article class=" bd-article-3">
            <h1 class=" bd-postheader-3"  itemprop="name">
                        <a href="/news/politics/amidu-s-appointment-should-end-witch-hunting-cries-akufo-addo.html">
                Amidu’s appointment should end witch-hunting cries – Akufo-Addo            </a>
            </h1>
	
		<div class=" bd-layoutbox-8 bd-no-margins clearfix">
    <div class="bd-container-inner">
        <div class=" bd-posticondate-4 bd-no-margins">
    <span class=" "><span><time datetime="2018-07-03T07:48:06+00:00" itemprop="datePublished">Date: Jul 03 , 2018 , 07:48</time></span></span>
</div>
	
		<div class=" bd-posticonauthor-5 bd-no-margins">
    <span class=" "><span>Author: Graphic.com.gh</span></span>
</div>
	
		<div class=" bd-posticoncategory-9 hidden-xs bd-no-margins">
    <span class=" "><span>Category: <span class="bd-post-metadata-category-name" itemprop="genre">Politics</span></span></span>
</div>
    </div>
</div>
	
		<div class=" bd-layoutbox-10 bd-no-margins clearfix">
    <div class="bd-container-inner">
        <div class=" bd-postimage-3 bd-no-margins pull-none">
    
            <img src="/images/2018/july/03/nana_mauritius.jpg" alt="President Akufo-Addo at the 31st AU Summit, exchanging pleasantries with an official of the EU" class=" bd-imagestyles-16" itemprop="image"/>
            
        <div class=" bd-container-54 bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed ">
        President Akufo-Addo at the 31st AU Summit, exchanging pleasantries with an official of the EU    </div>
    </div>
	
		<div class=" bd-customhtml-4 bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
    <div class="bd-container-inner bd-content-element">
        <div class="sharethis-inline-share-buttons"></div>    </div>
</div>
	
		<div class=" bd-postcontent-3 bd-tagstyles bd-custom-blockquotes bd-custom-image bd-custom-bulletlist bd-custom-table bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed bd-contentlayout-offset"  itemprop="articleBody">
    <h2>President Nana Addo Dankwa Akufo-Addo says the appointment of Mr. Martin Amidu as Ghana’s first Special Prosecutor will deny persons who will be investigated and prosecuted for engaging in acts of corruption, the often-cited refrain of witch-hunting.</h2>
 
<p>According to President Akufo-Addo, “we have a particular problem in Ghana which is that, every time a prosecution is mounted against a high ranking official, you hear the cry witch-hunting. It has become a way of protest for senior political figures.”</p><ins data-revive-zoneid="14" data-revive-ct0="{clickurl_enc}" data-revive-id="9498a47af2f5e17dd932fffda2cedac3"></ins>
<amp-ad width='336' height='280' type='adsense' data-ad-client='ca-pub-5510276167635361'
data-ad-slot='9768827792'></amp-ad>
<p>As a result, the President explained that “we have now had to devise particular responses and mechanisms (to the cry of witch-hunting). We have established an Office of Special Prosecutor. The Special Prosecutor is a permanent official who is independent of the Executive, who will hold all officials, past and present, accountable for their stewardship.”</p>
<p>President Akufo-Addo made this known last Sundaywhen he made an intervention at the plenary session of the 31st African Union Summit, which is being held on the theme “Winning the Fight against Corruption: A Sustainable path to Africa’s Transformation”, in Nouakchott, Mauritania.</p>
<p>Reiterating the commitment of his government to ensuring that “equality before the law means exactly just that, equality before the law”, President Akufo-Addo was unequivocal that regardless of one’s status in society, “when we get into problems of wrongdoing, we should face the consequences”.</p>
<p>Describing the Ghana’s first Special Prosecutor, Mr. Martin Amidu, as having “a high reputation on his stance on corruption and (being) a figure of integrity”, the President noted that Mr Amidu was a former Attorney General in the government of the 3rd President of the 4th Republic, the late John Evans Atta-Mills.</p><div align="center">
<ins data-revive-zoneid="12" data-revive-ct0="{clickurl_enc}" data-revive-id="9498a47af2f5e17dd932fffda2cedac3"></ins>
<br>
<ins data-revive-zoneid="15" data-revive-ct0="{clickurl_enc}" data-revive-id="9498a47af2f5e17dd932fffda2cedac3"></ins>
</div>
<p>“If he (Martin Amidu) then puts you in his gaze for an act of wrongdoing, that charge of witch-hunting will no longer be available. We believe that, that is a very important step, which will make sure that the principle of equality before the law is made meaningful.“</p><div class="sp-comments-container">
		<div id="fb-root"></div>
		<script>(function(d, s, id) {
			var js, fjs = d.getElementsByTagName(s)[0];
			if (d.getElementById(id)) return;
			js = d.createElement(s); js.id = id;
			js.src = "//connect.facebook.net/en-gb/sdk.js#xfbml=1&appId=342494502508165&version=v2.0";
			fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script>

		<div class="fb-comments" data-href="https://www.graphic.com.gh/news/politics/amidu-s-appointment-should-end-witch-hunting-cries-akufo-addo.html" data-numposts="10" data-width="500" data-colorscheme="light"></div>
	</div></div>
	
		    </div>
</div>
        </article>
        <div class="bd-container-inner"></div>
        
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div>
</div>

</div>
</div>

                    
                     <aside class="bd-sidebararea-4-column  bd-flex-vertical bd-flex-fixed ">
                <div class="bd-sidebararea-4 bd-flex-wide  bd-margins">
                    
                    <div class=" bd-joomlaposition-14 clearfix" >
            <div class=" bd-block-29 bd-own-margins list-gray thumb-3x visible-xs sharp_font" >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <h4>Latest News in Ghana</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        
<div class="allmode-box allmode-list list-gray thumb-3x visible-xs sharp_font">


<ul class="allmode-items">

	

	
		<li class="allmode-item allmode-category-id9 allmode-featured">

						<div class="allmode-img"><a href="/news/politics/ken-agyapong-faces-privileges-committee-of-parliament-today.html"><img src="/images/raxo_thumbs/amp/tb-w120-h80-crop-int-3fe2aeaf3b3a290b498bb5b519fd00ea.jpg" width="120" height="80" title="Ken Agyapong faces Privileges Committee of Parliament today" alt="Kennedy Agyapong" /></a></div>
			
						<div class="allmode-date">Jul 03, 2018</div>
			
			<div class="allmode-right">

								<h4 class="allmode-title"><a href="/news/politics/ken-agyapong-faces-privileges-committee-of-parliament-today.html">Ken Agyapong faces Privileges Committee of Parliament today</a></h4>
				
								<div class="allmode-info">

										<span class="allmode-category">Politics</span>
					
					
					
					
					
				</div>
				
				
			</div>

			<a href="/news/politics/ken-agyapong-faces-privileges-committee-of-parliament-today.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item allmode-category-id10 allmode-featured">

						<div class="allmode-img"><a href="/news/general-news/aayalolo-drivers-on-strike-for-unpaid-salaries.html"><img src="/images/raxo_thumbs/amp/tb-w120-h80-crop-int-7d732f82f07131aaf047147d07028207.jpg" width="120" height="80" title="Aayalolo drivers on strike for unpaid salaries" alt="" /></a></div>
			
						<div class="allmode-date">Jul 03, 2018</div>
			
			<div class="allmode-right">

								<h4 class="allmode-title"><a href="/news/general-news/aayalolo-drivers-on-strike-for-unpaid-salaries.html">Aayalolo drivers on strike for unpaid salaries</a></h4>
				
								<div class="allmode-info">

										<span class="allmode-category">General News</span>
					
					
					
					
					
				</div>
				
				
			</div>

			<a href="/news/general-news/aayalolo-drivers-on-strike-for-unpaid-salaries.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item allmode-category-id9 allmode-featured">

						<div class="allmode-img"><a href="/news/politics/cpp-questions-processes-for-ec-commissioners-removal.html"><img src="/images/raxo_thumbs/amp/tb-w120-h80-crop-int-ed3adfba846ee25de674fc9c9014b116.jpg" width="120" height="80" title="CPP questions processes for EC commissioners removal" alt="" /></a></div>
			
						<div class="allmode-date">Jul 03, 2018</div>
			
			<div class="allmode-right">

								<h4 class="allmode-title"><a href="/news/politics/cpp-questions-processes-for-ec-commissioners-removal.html">CPP questions processes for EC commissioners removal</a></h4>
				
								<div class="allmode-info">

										<span class="allmode-category">Politics</span>
					
					
					
					
					
				</div>
				
				
			</div>

			<a href="/news/politics/cpp-questions-processes-for-ec-commissioners-removal.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item allmode-category-id10 allmode-featured">

						<div class="allmode-img"><a href="/news/general-news/claims-nana-addo-victimised-charlotte-osei-flawed-emile-short.html"><img src="/images/raxo_thumbs/amp/tb-w120-h80-crop-int-73227ecb7dad2794e9ef54d51c051942.jpg" width="120" height="80" title="Claims Nana Addo victimised Charlotte Osei flawed – Emile Short" alt="Claims Nana Addo victimised Charlotte Osei flawed – Emile Short" /></a></div>
			
						<div class="allmode-date">Jul 03, 2018</div>
			
			<div class="allmode-right">

								<h4 class="allmode-title"><a href="/news/general-news/claims-nana-addo-victimised-charlotte-osei-flawed-emile-short.html">Claims Nana Addo victimised Charlotte Osei flawed – Emile Short</a></h4>
				
								<div class="allmode-info">

										<span class="allmode-category">General News</span>
					
					
					
					
					
				</div>
				
				
			</div>

			<a href="/news/general-news/claims-nana-addo-victimised-charlotte-osei-flawed-emile-short.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item allmode-category-id36">

						<div class="allmode-img"><a href="/sports/sports-news/neymar-shines-as-brazil-beat-mexico.html"><img src="/images/raxo_thumbs/amp/tb-w120-h80-crop-int-2c66499ba1bdbcbb99753d9b21de8f66.jpg" width="120" height="80" title="Neymar shines as Brazil beat Mexico" alt="Main man: Neymar celebrates after scoring the opener." /></a></div>
			
						<div class="allmode-date">Jul 02, 2018</div>
			
			<div class="allmode-right">

								<h4 class="allmode-title"><a href="/sports/sports-news/neymar-shines-as-brazil-beat-mexico.html">Neymar shines as Brazil beat Mexico</a></h4>
				
								<div class="allmode-info">

										<span class="allmode-category">Sports News</span>
					
					
					
					
					
				</div>
				
				
			</div>

			<a href="/sports/sports-news/neymar-shines-as-brazil-beat-mexico.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item allmode-category-id36 allmode-featured">

						<div class="allmode-img"><a href="/sports/sports-news/germany-jerome-boateng-rejects-calls-to-retire.html"><img src="/images/raxo_thumbs/amp/tb-w120-h80-crop-int-63d5c93a3def484ea377b41b4a2e35f8.jpg" width="120" height="80" title="Germany: Jerome Boateng rejects calls to retire" alt="Germany: Jerome Boateng rejects calls to retire" /></a></div>
			
						<div class="allmode-date">Jul 02, 2018</div>
			
			<div class="allmode-right">

								<h4 class="allmode-title"><a href="/sports/sports-news/germany-jerome-boateng-rejects-calls-to-retire.html">Germany: Jerome Boateng rejects calls to retire</a></h4>
				
								<div class="allmode-info">

										<span class="allmode-category">Sports News</span>
					
					
					
					
					
				</div>
				
				
			</div>

			<a href="/sports/sports-news/germany-jerome-boateng-rejects-calls-to-retire.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item allmode-category-id10">

						<div class="allmode-img"><a href="/news/general-news/adisadel-kicks-out-mfantsipim-and-ghana-national-to-get-booked.html"><img src="/images/raxo_thumbs/amp/tb-w120-h80-crop-int-c0f0190303c6d013e8307bf1b3ebc7cb.jpg" width="120" height="80" title="Adisadel mashes Mfantsipim and grills Ghana National College in NSMQ" alt="Adisadel mashes Mfantsipim and grills Ghana National College in NSMQ" /></a></div>
			
						<div class="allmode-date">Jul 02, 2018</div>
			
			<div class="allmode-right">

								<h4 class="allmode-title"><a href="/news/general-news/adisadel-kicks-out-mfantsipim-and-ghana-national-to-get-booked.html">Adisadel mashes Mfantsipim and grills Ghana National College in NSMQ</a></h4>
				
								<div class="allmode-info">

										<span class="allmode-category">General News</span>
					
					
					
					
					
				</div>
				
				
			</div>

			<a href="/news/general-news/adisadel-kicks-out-mfantsipim-and-ghana-national-to-get-booked.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item allmode-category-id43 allmode-featured">

						<div class="allmode-img"><a href="/lifestyle/life/study-reveals-main-reason-why-women-are-freezing-their-eggs.html"><img src="/images/raxo_thumbs/amp/tb-w120-h80-crop-int-4be4db29c00d8a70ad82c98db841f846.jpg" width="120" height="80" title="Study reveals main reason why women are freezing their eggs" alt="Study reveals main reason why women are freezing their eggs" /></a></div>
			
						<div class="allmode-date">Jul 02, 2018</div>
			
			<div class="allmode-right">

								<h4 class="allmode-title"><a href="/lifestyle/life/study-reveals-main-reason-why-women-are-freezing-their-eggs.html">Study reveals main reason why women are freezing their eggs</a></h4>
				
								<div class="allmode-info">

										<span class="allmode-category">Life</span>
					
					
					
					
					
				</div>
				
				
			</div>

			<a href="/lifestyle/life/study-reveals-main-reason-why-women-are-freezing-their-eggs.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item allmode-category-id10">

						<div class="allmode-img"><a href="/news/general-news/95-pwds-in-ketu-south-receive-livelihood-support-packages.html"><img src="/images/raxo_thumbs/amp/tb-w120-h80-crop-int-a6779cd2cd8ce5b7f788777bac69fcf5.jpg" width="120" height="80" title="95 PWDs in Ketu South receive livelihood support packages" alt="" /></a></div>
			
						<div class="allmode-date">Jul 02, 2018</div>
			
			<div class="allmode-right">

								<h4 class="allmode-title"><a href="/news/general-news/95-pwds-in-ketu-south-receive-livelihood-support-packages.html">95 PWDs in Ketu South receive livelihood support packages</a></h4>
				
								<div class="allmode-info">

										<span class="allmode-category">General News</span>
					
					
					
					
					
				</div>
				
				
			</div>

			<a href="/news/general-news/95-pwds-in-ketu-south-receive-livelihood-support-packages.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item allmode-category-id36 allmode-featured">

						<div class="allmode-img"><a href="/sports/sports-news/liverpool-mohamed-salah-signs-new-five-year-deal.html"><img src="/images/raxo_thumbs/amp/tb-w120-h80-crop-int-c45bd4d279665e85dab0ef89feaef1a5.jpg" width="120" height="80" title="Liverpool: Mohamed Salah signs new five-year deal" alt="Liverpool: Mohamed Salah signs new five-year deal" /></a></div>
			
						<div class="allmode-date">Jul 02, 2018</div>
			
			<div class="allmode-right">

								<h4 class="allmode-title"><a href="/sports/sports-news/liverpool-mohamed-salah-signs-new-five-year-deal.html">Liverpool: Mohamed Salah signs new five-year deal</a></h4>
				
								<div class="allmode-info">

										<span class="allmode-category">Sports News</span>
					
					
					
					
					
				</div>
				
				
			</div>

			<a href="/sports/sports-news/liverpool-mohamed-salah-signs-new-five-year-deal.html" class="allmode-readmore"></a>

		</li>

	
</ul>
</div>
    </div>
    
</div>
        </div>                    
                </div>
            </aside>
                        </div>
                
                     <aside class="bd-sidebararea-2-column  bd-flex-vertical bd-flex-fixed ">
                <div class="bd-sidebararea-2 bd-flex-wide  bd-contentlayout-offset">
                    
                    <div class=" bd-joomlaposition-56 clearfix" >
            <div class=" bd-block-53 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-custom-orderedlist bd-custom-table bd-bootstrap-tables bd-table-striped bd-table-hover">
        <ins data-revive-zoneid="4" data-revive-ct0="{clickurl_enc}" data-revive-id="9498a47af2f5e17dd932fffda2cedac3"></ins>    </div>
    
</div>
        </div>
        	
		    
        <div class=" bd-joomlaposition-49 clearfix" >
            <div class=" bd-block-42 bd-own-margins  adankustyle hidden-xs" >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <h4>More Ghana news headlines</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-inputs bd-custom-bulletlist bd-custom-orderedlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <ol type="1" class="category-module adankustyle hidden-xs">
						<li>
									<a class="mod-articles-category-title " href="/news/politics/freddie-blay-gets-support-from-b-a.html">Freddie Blay gets support from B/A</a>
				
				
				
				
				
				
							</li>
					<li>
									<a class="mod-articles-category-title " href="/news/politics/amidu-s-appointment-should-end-witch-hunting-cries-akufo-addo.html">Amidu’s appointment should end witch-hunting cries – Akufo-Addo</a>
				
				
				
				
				
				
							</li>
					<li>
									<a class="mod-articles-category-title " href="/news/politics/ken-agyapong-faces-privileges-committee-of-parliament-today.html">Ken Agyapong faces Privileges Committee of Parliament today </a>
				
				
				
				
				
				
							</li>
					<li>
									<a class="mod-articles-category-title " href="/news/politics/cpp-questions-processes-for-ec-commissioners-removal.html">CPP questions processes for EC commissioners removal</a>
				
				
				
				
				
				
							</li>
					<li>
									<a class="mod-articles-category-title " href="/news/politics/arthur-k-writes-on-constitutions-leaders-and-courts.html">Arthur K writes on Constitutions, Leaders and Courts</a>
				
				
				
				
				
				
							</li>
					<li>
									<a class="mod-articles-category-title " href="/news/politics/disclaimer-i-have-not-written-anything-on-ec-matter-john-ndebugre.html">Disclaimer: I have not written anything on EC matter - John Ndebugre</a>
				
				
				
				
				
				
							</li>
					<li>
									<a class="mod-articles-category-title " href="/news/politics/rawlings-ebow-tawiah-was-a-humble-man-of-integrity.html">Rawlings: Ebow Tawiah was a humble man of integrity</a>
				
				
				
				
				
				
							</li>
					<li>
									<a class="mod-articles-category-title " href="/news/politics/retired-state-prosecutor-in-who-watches-the-watchman-video-responds-to-ken-agyapong.html">Retired state prosecutor in ‘Who watches the watchman’ video responds to Ken Agyapong</a>
				
				
				
				
				
				
							</li>
					<li>
									<a class="mod-articles-category-title " href="/news/politics/be-wary-of-voices-urging-you-to-appoint-x-or-y-to-ec-prof-asare-to-akufo-addo.html">Be wary of voices urging you to appoint X or Y to EC - Prof Asare to Akufo-Addo</a>
				
				
				
				
				
				
							</li>
					<li>
									<a class="mod-articles-category-title " href="/news/politics/ec-left-with-only-3-members-akufo-addo-looking-for-4-to-replace.html">EC left with only 3 commissioners; Akufo-Addo looking for 4 to replace</a>
				
				
				
				
				
				
							</li>
			</ol>
    </div>
    
</div>
        <div class=" bd-block-42 bd-own-margins  hidden-xs" >
            
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-inputs bd-custom-bulletlist bd-custom-orderedlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <ins data-revive-zoneid="5" data-revive-id="9498a47af2f5e17dd932fffda2cedac3"></ins>    </div>
    
</div>
        </div>
        	
		    
        <div class=" bd-joomlaposition-61 clearfix" >
            <div class=" bd-block-73 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        

<div class="custom"  >
	<div id="taboola-right-rail-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-rr',
    container: 'taboola-right-rail-thumbnails',
    placement: 'Right Rail Thumbnails',
    target_type: 'mix'
  });
</script></div>
    </div>
    
</div>
        </div>                    
                </div>
            </aside>
                    </div>
            
        </div>

    </div>
</div></div>
	
		<footer class=" bd-footerarea-1 bd-textureoverlay bd-textureoverlay-1 bd-margins">
        <section class=" bd-section-2 bd-tagstyles bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed" id="footersection" data-section-title="Footer With Links">
    <div class="bd-container-inner bd-margins clearfix">
        <div class=" bd-layoutcontainer-48 bd-columns bd-no-margins">
    <div class="bd-container-inner">
        <div class="container-fluid">
            <div class="row ">
                <div class=" bd-columnwrapper-76 
 col-sm-6">
    <div class="bd-layoutcolumn-76 bd-column" ><div class="bd-vertical-align-wrapper"></div></div>
</div>
	
		<div class=" bd-columnwrapper-78 
 col-sm-6">
    <div class="bd-layoutcolumn-78 bd-column" ><div class="bd-vertical-align-wrapper"></div></div>
</div>
            </div>
        </div>
    </div>
</div>
	
		<div class=" bd-layoutbox-9 bd-no-margins bd-no-margins clearfix">
    <div class="bd-container-inner">
        <div class=" bd-spacer-2 clearfix"></div>
	
		<div class=" bd-layoutcontainer-17 hidden-sm hidden-xs bd-columns bd-no-margins">
    <div class="bd-container-inner">
        <div class="container-fluid">
            <div class="row ">
                <div class=" bd-columnwrapper-39 
 col-lg-2
 col-sm-2">
    <div class="bd-layoutcolumn-39 bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-3 hidden-xs clearfix" >
            <div class=" bd-block-32 bd-own-margins _menu" >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <h4>About GCGL</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <ul class=""><li class="item-145"><a href="#"><span>About Us</span></a></li><li class="item-146"><a title="Terms of Use" href="/terms-of-use.html"><span>Terms Of Use</span></a></li><li class="item-151"><a title="Sitemap for Graphic Online" href="/sitemap.html"><span>Sitemap</span></a></li><li class="item-302"><a title="Daily Graphic Articles" href="/daily-graphic-newspaper.html"><span>Daily Graphic Newspaper</span></a></li></ul>    </div>
    
</div>
        </div>
        </div></div>
</div>
	
		<div class=" bd-columnwrapper-24 
 col-lg-2
 col-sm-2">
    <div class="bd-layoutcolumn-24 bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-27 hidden-xs clearfix" >
            <div class=" bd-block-34 bd-own-margins _menu" >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <h4>News</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <ul class=""><li class="item-152 active"><a href="/news/politics.html"><span>Ghana Politics</span></a></li><li class="item-153"><a href="/news/general-news.html"><span>News in Ghana</span></a></li><li class="item-156"><a title="Ghana Sports and Football News" href="/sports/sports-news.html"><span>Sports News</span></a></li><li class="item-157"><a href="/international.html"><span>World News</span></a></li><li class="item-158"><a href="/?Itemid="><span>Teenage News</span></a></li><li class="item-301"><a title="Daily Graphic Editorials" href="/daily-graphic-editorials.html"><span>Editorials</span></a></li></ul>    </div>
    
</div>
        </div>
        </div></div>
</div>
	
		<div class=" bd-columnwrapper-23 
 col-lg-2
 col-sm-2">
    <div class="bd-layoutcolumn-23 bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-24 hidden-xs clearfix" >
            <div class=" bd-block-36 bd-own-margins _menu" >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <h4>Columnists</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <ul class=""><li class="item-171"><a title="From my roof Top - Kofi Akordor Daily Graphic columnist" href="/from-my-roof-top.html"><span>From my roof Top</span></a></li><li class="item-172"><a href="/voice-from-afar.html"><span>Voice from afar</span></a></li><li class="item-173"><a href="/the-view-from-here.html"><span>The view from here</span></a></li><li class="item-174"><a title="Elizabeth Ohene - Daily Graphic Columnist" href="/elizabeth-ohene.html"><span>Elizabeth Ohene</span></a></li><li class="item-176"><a href="/native-daughter.html"><span>Native Daughter</span></a></li><li class="item-177"><a title="Thinking Aloud Column: Daily Graphic" href="/thinking-aloud.html"><span>Thinking Aloud</span></a></li><li class="item-178"><a href="#"><span>Civic Realities</span></a></li><li class="item-217"><a href="/personality-profiles.html"><span>Personality Profiles</span></a></li></ul>    </div>
    
</div>
        </div>
        </div></div>
</div>
	
		<div class=" bd-columnwrapper-61 
 col-lg-2
 col-sm-2">
    <div class="bd-layoutcolumn-61 bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-16 hidden-xs clearfix" >
            <div class=" bd-block-133 bd-own-margins _menu" >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <h4>Graphic Websites</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <ul class=""><li class="item-159"><a href="#"><span>Graphic News App</span></a></li><li class="item-160"><a href="#"><span>Graphic Classifieds</span></a></li><li class="item-161"><a href="#"><span>Graphic Showbiz</span></a></li><li class="item-162"><a href="#"><span>Graphic Sports</span></a></li><li class="item-163"><a href="#"><span>Graphic Business Online</span></a></li><li class="item-175"><a href="#"><span>Graphic e-Paper</span></a></li></ul>    </div>
    
</div>
        </div>
        </div></div>
</div>
	
		<div class=" bd-columnwrapper-60 
 col-lg-4
 col-sm-2">
    <div class="bd-layoutcolumn-60 bd-column" ><div class="bd-vertical-align-wrapper"><div class=" bd-socialicons-5">
    
        <a target="_blank" class=" bd-socialicon-56 bd-socialicon" href="//www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.graphic.com.gh%2Fnews%2Fpolitics%2Famidu-s-appointment-should-end-witch-hunting-cries-akufo-addo.html">
    <span class="bd-icon"></span><span></span>
</a>
    
        <a target="_blank" class=" bd-socialicon-57 bd-socialicon" href="//twitter.com/share?url=https%3A%2F%2Fwww.graphic.com.gh%2Fnews%2Fpolitics%2Famidu-s-appointment-should-end-witch-hunting-cries-akufo-addo.html&amp;text=Amidu%E2%80%99s+appointment+should+end+witch-hunting+cries+%E2%80%93+Akufo-Addo+-+Graphic+Online">
    <span class="bd-icon"></span><span></span>
</a>
    
        <a target="_blank" class=" bd-socialicon-58 bd-socialicon" href="//plus.google.com/share?url=https%3A%2F%2Fplus.google.com%2F%2Bdailygraphic">
    <span class="bd-icon"></span><span></span>
</a>
    
    
    
        <a target="_blank" class=" bd-socialicon-61 bd-socialicon" href="//instagram.com/graphic.com.gh">
    <span class="bd-icon"></span><span></span>
</a>
    
    
    
    
    
</div>
	
		    </div></div>
</div>
            </div>
        </div>
    </div>
</div>
	
		<div class="bd-separator-2  bd-separator-center bd-separator-content-center clearfix" >
    <div class="bd-container-inner">
        <div class="bd-separator-inner">
            
                <div class="bd-separator-content-268 bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed bd-no-margins  bd-separator-content" >
                    
                        
                            <a class="bd-imagelink-2  bd-own-margins"
                               href="https://www.graphic.com.gh/"
                               
                               
                               >
                                <img class=" bd-imagestyles"
                                     src="https://www.graphic.com.gh/images/2018/feb/onlinelogo.png"
                                     
 alt="Graphic Online Ghana Logo" >
                            </a>
                </div>
        </div>
    </div>
</div>
	
		    
        <div class=" bd-joomlaposition-5 clearfix" >
            <div class=" bd-block-207 bd-own-margins  sharp_fonts" >
            
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        

<div class="custom sharp_fonts"  >
	<p><a title="Subscribe for Graphic Email Newsletter" href="#">News in Your Mail</a> | <a title="Contact Graphic Online Team" href="#">Contact Us </a>| <a title="Subscribe to Ghana news RSS feeds from Daily Graphic" href="#">RSS Feeds</a> | <a title="Visit this page to Advertise with us" href="#">Advertise With Graphic</a> | <a title="Follow Graphic Online and Ghana News on Google plus" href="https://plus.google.com/+dailygraphic">Google+</a> | <a title="Follow Graphic Online on Twitter for latest news in Ghana" href="https://twitter.com/graphicgh">Twitter</a> |</p>
<p>© 2018. All Rights Reserved | Graphic Online | Owned and Operated by Graphic Communications Group Ltd.</p></div>
    </div>
    
</div>
        </div>
            </div>
</div>
    </div>
</section>
</footer>
	
		<div data-smooth-scroll data-animation-time="250" class=" bd-smoothscroll-10"><a href="#" class=" bd-backtotop-8 ">
    <span class="bd-icon-108 bd-icon "></span>
</a></div>
	
		


<script src="/plugins/system/GoogleAnalytics/vendor/directmonster2.0.2.js" type="text/javascript"></script> 
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-16927683-1', 'auto');
  ga('require', 'linkid', 'linkid.js');
  ga('require', 'displayfeatures');
  ga('set', 'anonymizeIp', true);
  ga('set', 'forceSSL', true);
  ga('send', 'pageview');
</script>
<!-- Universal Google Analytics PRO 4.6.3 Plugin by PB Web Development -->


</body>
</html>